Jump to content

Speedo not working


Recommended Posts

Hi guys just sorting out a few probs with the motor.

 

Ive already searched on here but couldnt really find anything. My speedo is a bit tempremental as in it hardly ever works so i dont know how fast im going! lol. Every other dial works (rev counter, odometer still puts the kph on. etc) Just my speedo never does!

 

How can i fix this?

 

Thanks all.

Link to comment
Share on other sites

  • advertisement_alt
  • advertisement_alt
  • advertisement_alt

The most common reason for speedo failure is a dailing KPH>MPH convertor on the back of the clocks if its a Jap import. Other reasons are Speed sensor on the Gearbox or a dry joint on the speedo cluster.

 

Does the Power steering get heavy as well ?

 

MOT testers do not check speedo operation.

Link to comment
Share on other sites

mine is also iffy but ever since i pulled the needles off. The needle does not keep up when you accelerate when it does catch up and you let off the power it sticks some times before dropping.

 

Still not working and really annoying my solution was a Defi VSD but not ideal.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...

Important Information

Terms of Use