Jump to content

Crystal Clear Indicator Issues


Recommended Posts

I noticed that one of the pieces of lens was missing from one of my front indicators.

Rather than try to find a replacement piece of lens, i decided to get whole new crystal clear fitments.

These have arrived, but there are a couple of issues i'd appreciate running by the helpful folks here:

 

-Any tips on fitting this? I tried removing the original lenses to have a look, but the screw just keeps turning and never comes out. Is there a bolt on the other side that is turning? Anyone have a how-to?

 

-The CC fitment has a hole for a sidelight bulb, while my original ones have this hole blanked out. I have checked the how-to on adding extra sidelights here (in the FAQ section here) and this seems like a good idea, but i'm not sure where i'd get the slot-in bulb holder that i'd need.

Link to comment
Share on other sites

I noticed that one of the pieces of lens was missing from one of my front indicators.

Rather than try to find a replacement piece of lens, i decided to get whole new crystal clear fitments.

These have arrived, but there are a couple of issues i'd appreciate running by the helpful folks here:

 

-Any tips on fitting this? I tried removing the original lenses to have a look, but the screw just keeps turning and never comes out. Is there a bolt on the other side that is turning? Anyone have a how-to?

 

-The CC fitment has a hole for a sidelight bulb, while my original ones have this hole blanked out. I have checked the how-to on adding extra sidelights here (in the FAQ section here) and this seems like a good idea, but i'm not sure where i'd get the slot-in bulb holder that i'd need.

 

 

The two screws go into a fixed nut - it is likely that the thread is stripped. If it keeps turning you should be able to pull the offending screw out using a pair of needle-nose plyers.

 

You can use the bulb holders for side repeaters. These are commonly found on many nissans and your best bet is to have a look at a local scrappy.

 

HTH

 

Dan

Link to comment
Share on other sites

OK thanks.

 

One thing i noticed is that the original ones have only 1 middle screw, whereas the replacements have two, top and bottom.

Is this a difference between models, or has someone maybe put a different fitment on in the past, hence the screw acting up?

Link to comment
Share on other sites

OK thanks.

 

One thing i noticed is that the original ones have only 1 middle screw, whereas the replacements have two, top and bottom.

Is this a difference between models, or has someone maybe put a different fitment on in the past, hence the screw acting up?

 

 

I'm afraid I've only ever seen originals with two screws - never seen one with just one in the middle. Have you a picture of the item? Could help clarify things.

 

Dan

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...

Important Information

Terms of Use