Jump to content

Turbo Advice


Recommended Posts

I have just looked at a UK TT and am in two minds whether to purchase. My only real concern is that the boost gauge doesn't work and I have read so many horror stories opn these cars that I reluctant to take much of a risk. I already have a N/A and this one definately feels considerably quicker through the revs. How can I tell is the turbos are any good without a gauge that is working correctly.

 

Also, is gauges packing up a common problem and how easy are they to fix.

 

Any advice appreciated.

Link to comment
Share on other sites

are you sure that its the gauge thats naff and not the turbos! :x:

if they are broken then the Z will probably be slightly slower than an N/A. if they are working... then you should be able to tell the difference ;)

aftermarket gauges are dead easy to install, just need to T off a pipe from the engine bay and feed through into the cockpit.

out of interest, where does the needle of the gauge sit? in the centre or to the left?

Link to comment
Share on other sites

are you sure that its the gauge thats naff and not the turbos! :x:

if they are broken then the Z will probably be slightly slower than an N/A. if they are working... then you should be able to tell the difference ;)

aftermarket gauges are dead easy to install, just need to T off a pipe from the engine bay and feed through into the cockpit.

out of interest, where does the needle of the gauge sit? in the centre or to the left?

 

Needle sits to the left. Appears to be pulling better than my NA but I can't say that it is blisteringly fast - which is what I expected.

Link to comment
Share on other sites

If it only feels slighly faster than your NA and not as fast as expected...then there is almost certainly a problem. Safety mode causes a substantial performance drop and is more than likely the issue...

 

Ideally you want to perform an ECU error code check on the car.

 

The boost gauge usually stops working becuase the vacumn pipe has come off just under the bonnet, drivers side wing. Connects to bottom of small black box near the small fuse box.

Link to comment
Share on other sites

If it only feels slighly faster than your NA and not as fast as expected...then there is almost certainly a problem. Safety mode causes a substantial performance drop and is more than likely the issue...

 

Ideally you want to perform an ECU error code check on the car.

 

The boost gauge usually stops working becuase the vacumn pipe has come off just under the bonnet, drivers side wing. Connects to bottom of small black box near the small fuse box.

 

Cheers Legarth. Might have another look after all.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...

Important Information

Terms of Use