Jump to content

Ghost in my machine


Recommended Posts

Having a prob with the lights on my UK spec Zed.

Started with the fog light coming on by its self followed by the o/s main beam a couple of hours later, I took the car for a drive hoping this might dry things off, now when I switch the lights off the o/s main beam comes on and the n/s dip stays on. I have had to dissconect all the offending lamps as the car was sitting outside all lit up with now where to, can some please help?

Also the boost gauge only works properly (I hope) when the lights are switched off.

Link to comment
Share on other sites

Had a problem once where I replaced a drivers side footwell fuse back in the wrong slot after checking them to find a blown fuse. What happened was that the main beam light came on all by themselves. I checked everything and then resorted to posting a question on the forum. From memory Jeff came to my rescue saying that it's a warning system built into the Nissan to indicate that this particular fuse (controls the lights) has blown.

 

Third row down, in the middle I think.

 

It's a Jap NA by the way.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...

Important Information

Terms of Use