Jump to content

not too sure what to call this problem


Recommended Posts

my speedo and pas have been cutting in and out on and off for a long time now.

 

after reading faq, I have come to the conclusion it was either a speed sender unit or the actual clocks them selves.

 

I have a new speed sender and pinion on order from nissan, I have just got some replacement "uk" clocks, my car is a jap non turbo but was told by several people that the uk tt dials are a straight swop and it will just be a redundant turbo gauge.

 

I have installed the clocks, when they arrived both the rev counter and speedo were red line/180mph respectably. When starting the car at first the rev counter didn't respond but after going round the block it started to work and now works fine, however the speedo is still sitrting at 180mph which could suggest that there is no signal and the problem is the speed sender, HOWEVER the trip mileage is turning round which suggests that I am getting a speed signal.

 

As far as I am aware the speed signal goes to the clocks then the speedo and out the back to the pas ecu? but the motor for the trip meter is plugged into the back of the dials which suggests it feeds straight from the dials and doesn't have a seperate speed signal to the speedo. However when tracing the printed board from the speedo, there is +, - , speed signal and a "speed output?" which goes directly back to the same connection block as the speed signal in suggesting it comes in, through speedo and off to ecu?

 

Does this mean that by coincidene my original dials were knackered and so is the replacement? or does it mean that the speed sender is broke and the trip mileage doesn't come from the speed sender? or that the speed sender is working but it doesn't go straight to dials but to some kind of distribution in the ecu and then a signal to speedo and a signal to trip meter sperately and pas seperately?

 

or should i give up and buy another car!?

Link to comment
Share on other sites

the old ones did, i removed that, put it back to kph, but still played up so I got these mph uk dials from a uk tt which DO NOT have a converter.

 

My old dials bonged at 100kph, these ones bong when I start the car, and if I pull up to stop! the speedo as yet to move from 180mph where it was before they were fitted, the rev counter was sat on red line before fitting, after a drive round the block the rev counter decided to start working, I have been for a long run but speedo still sitting on 180mph, but the trip meter goes round in accordance to the distance driven.

 

I had the power steering and speedo prob with the old dials installed, this was my reason for changing them. however they did work on occassion. My old trip meter used to work on and off which looked more like a speed signal loss, but is working fully on the new ones, but no speedo or pas.

Link to comment
Share on other sites

Guest andyduff

The loss of PAS and speedo is 99% of the time caused by the speedo converters. Sounds like the clocks you have are faulty possibly. Have you tried refitting your old dials? AFAIK UK clocks don't 'bong' either - they don't have a 'bonger' LOL. Could be wrong on this though :)

Link to comment
Share on other sites

apparently they bong in jap cars at 10mph or 100mph depending on where you choose to put a screw on the back of the unit.

 

I have now reset the needle by hand and speedo works.

 

I thought i'd solved it after a long drive but then pas starts getting jumpy and goes hard but speedo is still working this time.

 

I have tried disconnecting the plug to back of speedo establishing that the trip meter comes from the same signal and also the bong.

 

So do I have both a pas prob and previously a speedo prob?

Link to comment
Share on other sites

cheers, now how do I get the car to steer lol?

 

as said above try old clocks back in, make sure when you removed the speedo convertor you wired it back up properly

 

failing that it will most probably be your speed sensor which bolts to the side of your gearbox :cool: new one and your steering should be back to normal

Link to comment
Share on other sites

wound needle back on speedo by hand, speedo now works perfect all the time and so does trip meter, have recently done a 110 mile trip at the same time as someone else doing the same trip in another car, both trip meters both read 110 miles. So my speed signal must be working, but power steering was not working 40% of the trip. I assume that I had two probs, speedo which was cured by changing the clocks and now pas which was masked by the speedo prob. So if I am getting a constant speed signal but pas will suddenly go hard for awhile or judder about which does seem to happen when changing speeds even though I have a constant speed signal, could this be the pas ecu? another thing which makes me think this is possible is the heater matrix went when I had only had the car 2 months or so, the pas seemed to play up just before this, could the pas ecu be water damaged?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...

Important Information

Terms of Use