Jump to content

Recommended Posts

Hi guys just a theoretical question.What would happen if my EGR pipes were leaking badly? As i have found that both pipes have lost a bolt and the others have come loose under the plenum.

The car ticks over but wont drive over 2000rpm however it will rev when not under load.

Could this be the cause of my problem?

Thanks

Steve.

Link to comment
Share on other sites

Hi guys just a theoretical question.What would happen if my EGR pipes were leaking badly? As i have found that both pipes have lost a bolt and the others have come loose under the plenum.

The car ticks over but wont drive over 2000rpm however it will rev when not under load.

Could this be the cause of my problem?

Thanks

Steve.

 

sounds like your air flow meter's disconnected or failed... but can't remember if the failsafe works under no load or not?!? Limiting the revs to 2000 will be the ECU (assuming you mean EXACTLY 2000 rather than struggling if you see what I mean).

 

Rich

Link to comment
Share on other sites

What i cant understand is that it only does it while im driving.At a standstill it will rev its nuts off.

A knackered MAF will allow the engine to run mate, dunno if it's because the ECU is a closed loop application until around 2.5k not sure.

Totally disconnect it and see if the symtoms are excatly the same.

smithy

Link to comment
Share on other sites

A knackered MAF will allow the engine to run mate, dunno if it's because the ECU is a closed loop application until around 2.5k not sure.

Totally disconnect it and see if the symtoms are excatly the same.

smithy

Cheers guys i will try the above and see what happens.

Link to comment
Share on other sites

  • Trade

your fault is purely down to the loose egr pipe.the symptons youve described are typical of a serious boost leak.when the turbos boost which is in the range you described the car will try to compensate but cant.the fault wont appear at standstill as the engine is not under the same load as when you drive it.fix the leak and im pretty sure the fault will be cured.seen an identical problem to this before and a leaking intercooler was the problem.

Untitled-1.png
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...

Important Information

Terms of Use